Menu Close

Firefox tweaks – add-on’s compatibility

This and that is not compatible with your version of Firefox! You what?! yes it happens, there it is on your list of all your precious add-ons, you update your Firefox to the latest and greatest.

You sit there while it loads up, and up comes that addons version checker to see if there are any updates, with your breath held, you start to go blue – its taking longer than usual.. DAMN IT! A few failed!

Most of the good add-ons will indeed be updated in the nightly updates, but there are ones that seem to hang about for weeks or months on end before the author decides to get his arse in gear!

Here’s what to do!

Goto your Firefox address bar and type in about:config press return, and appears that scary list that you know not to play with – but some of you do anyway! 😛

right click somewhere, select new boolean

enter extensions.checkCompatibility then set to false

add more new booleans and set to all false

extensions.checkCompatibility3.0

extensions.checkCompatibility3.5

extensions.checkCompatibility3.6

extensions.checkCompatibility3.7a

extensions.checkCompatibility4.0

extensions.checkCompatibility4.0b

extensions.checkCompatibility5.0

You can keep doing this for all versions if need be (it goes up to 7 at present).

At this point you can go back to your add-ons window or tab, and if they aren’t enabled for you automatically, then please enable the ones you wish to use again. It will mention to restart – restart.

All should be well.

255 total views, 5 views today

Leave a Reply

avatar

This site uses Akismet to reduce spam. Learn how your comment data is processed.

  Subscribe  
Notify of